Upgrade Script

Check for After Dark updates and upgrade effortlessly.

To check for updates and automatically upgrade After Dark to the latest version simply run the upgrade script from your site directory:

cd flying toasters && \
./themes/after-dark/bin/upgrade

If you’re already using the latest version the script will let you know:

Did not upgrade after-dark. Already using latest version.

If an update is available the script will download and install it automatically:

Starting upgrade from 6.7.6 to 6.8.0 ...
Version 6.8.0 downloaded to themes/after-dark
Stopping help server if running ...
Generating help documentation ...
Upgrade complete! Please see CHANGELOG.md for changes.

If current version can’t be detected the script will prompt you:

Cannot detect version. Upgrade after-dark anyway (y/n)? y
Starting upgrade from unknown version to 6.12.1 ...
Version 6.12.1 downloaded to themes/after-dark
Stopping help server if running ...
Generating help documentation ...
Upgrade complete! Please see CHANGELOG.md for changes.

Like Quick Install the upgrade script is written to POSIX standard will not require additional dependencies to operate on most systems. Upon upgrade the Release Hash will update as well so you may Validate Release.

Connecting to server…
0 hashes (0 h/s)